Tag Archives: Fast V-Sync

For fucks sake NVIDIA, fix your Fast V-Sync shit with Opera/Chrome browser videos

I haven’t ranted for a while and this seems like a perfect opportunity to do so. This time it’s for “always absolutely perfect” NVIDIA’s ForceWare drivers that everyone praises so much…

Quite some time ago, I’ve switched to Opera browser because everything else is quite frankly shit because of various things, but especially because of dumb ass GPU blacklisting which makes my AMD E-450 APU useless. But Opera allows disabling of this GPU blacklist and I get my HW acceleration back on that old but still perfectly capable APU. So I use Opera on all my systems now. And I’ve noticed that if you have Fast V-Sync or Adaptive V-Sync enabled globally, ALL videos in Opera browser will be all fucked up, stuttering, video shifting inside itself, flickering, annoying as fuck. I didn’t notice this before, because I was using Firefox where even with Fast V-Sync enabled, videos play fine. Just not on anything Chrome based, be it actual Chrome or Opera (and even Vivaldi). So, I’ve filled a bug report to NVIDIA. That was months ago and they still haven’t fixed their shit. I’ve tried as far back as drivers from January 2017 and they all have this fucking bug that for some reason no one else seems to have spotted. Apparently 90% of people don’t have a clue how cool Fast V-Sync is otherwise so they don’t even experience this shit. I use Fast V-Sync for all games because it removes tearing and has no input lag unlike normal V-Sync.

Here’s a kicker though. Windows 10, even though I’ve installed ancient drivers to try and solve an issue, it auto installed newer drivers on its own (Microsoft, stop fucking up with drivers without my fucking permission you utter twats). However, while I’m pissed at Microsoft for doing that, the drivers from May 1st 2017 version 382.05 that get auto installed by Win10 DON’T have this bug for some fucked up reason. It’s especially more fucked up because all the drivers after it from NVIDIA again have this retarded bug. So, why do ALL the drivers before and after ForceWare 382.05 have this stupid bug, but this one doesn’t? And more importantly, why the fuck NVIDIA hasn’t fixed it yet for months?

This shit is pissing me off so much I’m seriously considering just going to AMD with the RX Vega because NVIDIA apparently just doesn’t give a fuck if this crap can’t get fixed for months. Especially now that AMD has Enhanced Sync which is the same as Fast V-Sync. And hopefully with no such retarded issue… What good is all this awesome framerate and shit from NVIDIA if they fuck up basic shit like video playback in most widely used browser engine (Chrome) in connection with one of their most useful features for games? Aaargh