Sound Blaster Z Surround setting disabling by itself

Do you happen to own a Sound Blaster Recon3D or Sound Blaster Z/Zx/ZxR and your “Surround” option keeps on getting disabled for no obvious reason?


Yeah, that one. Surround feature, as much as people hate it for music and movies, it’s fantastic for games. It makes sounds that pass through different speaker channels a lot smoother or gradient if you want. When there is a stationary continuous noise in a game, try rotating around your own axis. Sound will pass from one speaker to another. Without Surround feature enabled, sound will usually be cut and transitioned to another speaker where with Surround enabled, it will fade away in a more natural way and transition to another speaker channel, creating a lot more natural and smooth audio environment. Similar to how our ears perceive it in real world.

Anyway, this feature was getting disabled on its own and I couldn’t figure it out why. And then some nice chap gave me an answer on Creative Labs Forums. The culprit for this is ALchemy. If you use Creative Alchemy to re-enable DirectSound3D audio for older games, it will disable the Surround when you run that game. After testing, that was indeed the case, because I’m just playing F.E.A.R. and I also use ALchemy so I can have HW Audio Acceleration and all the EAX HD effects fully enabled. Every time I ran F.E.A.R. Surround setting was disabled.

There is a partial solution to this until Creative fixes it. You can Alt+Tab (or Ctrl+Esc) a game, open the above Creative panel and manually re-enable Surround. It does work.

Hope it helps for anyone having the same annoyance…

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s